题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=6077

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1363    Accepted Submission(s): 926

Problem Description

Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has 5 alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.


Your job is to help Little Q read the time shown on his clock.

Input

The first line of the input contains an integer T(1≤T≤1440), denoting the number of test cases.

In each test case, there is an 7×21 ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.

Output

For each test case, print a single line containing a string t in the format of HH:MM, where t(00:00≤t≤23:59), denoting the time shown on the clock.

Sample Input

1
.XX...XX.....XX...XX.
X..X....X......X.X..X
X..X....X.X....X.X..X
......XX.....XX...XX.
X..X.X....X....X.X..X
X..X.X.........X.X..X
.XX...XX.....XX...XX.

Sample Output

02:38

思路:找一下对应数字之间的规律

参考代码:

#include<iostream>
#include<cstdio>
using namespace std;
char a[7][21];
int vj(int id)
{
    if (a[0][id + 1] == 'X')
    {
        if (a[1][id] == 'X')
        {
            if (a[1][id + 3] == 'X')
            {
                if (a[3][id + 1] == 'X')
                {
                    if (a[4][id] == 'X')
                        return 8;
                    else
                        return 9;
                }
                else
                {
                    return 0;
                }
            }
            else
            {
                if (a[4][id] == 'X')
                    return 6;
                else
                    return 5;
            }
        }
        else
        {
            if (a[4][id] == 'X')
                return 2;
            else if (a[3][id+1] == 'X')
                return 3;
            else
                return 7;
        }
    }
    else
    {
        if (a[1][id] == 'X')
            return 4;
        else
            return 1;
    }
}
void solve()
{
    int a,b,c,d;
    a=vj(0);
    b=vj(5);
    c=vj(12);
    d=vj(17);
    printf("%d%d:%d%d\n",a,b,c,d);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        for(int i=0; i<7; i++)
            scanf("%s",a[i]);
        solve();
    }
    return 0;
}
/*
92:38
.XX...XX.....XX...XX.
X..X....X......X.X..X
X..X....X.X....X.X..X
.XX...XX.....XX...XX.
...X.X....X....X.X..X
...X.X.........X.X..X
.XX...XX.....XX...XX.

02:38
.XX...XX.....XX...XX.
X..X....X......X.X..X
X..X....X.X....X.X..X
......XX.....XX...XX.
X..X.X....X....X.X..X
X..X.X.........X.X..X
.XX...XX.....XX...XX.
*/