Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game? 
 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!". 
 

Sample Input

5 3 5 4 6 6 0 0
 

Sample Output

What a pity! Wonderful! Wonderful!
 

Source


博弈又快忘了,记住了又能怎样……

本题是在方格子中顺着左、下、左下的方向动,若长和宽有一个为偶数,那么kiki就可以顺着这个方向有路可走

#include <iostream>
#include<cstdio>
using namespace std;
int n,m;
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0) break;
        if(n%2&&m%2)
        puts("What a pity!");
        else
        puts("Wonderful!");
    }
    return 0;
}