题目链接:传送门

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0

#include<iostream>
#include<string>
#include<cstdio>
#include<map>
#include<cstring>
using namespace std;
int main()
{
    int a,b,c,d,e,f;
    char s[100],w[100];
    map<string,int>m;
    while(gets(s))
    {
        a=strlen(s);
        if(a==0)
            break;
        for(b=a;b>0;b--)
        {
            s[b]='\0';
            m[s]++;
        }
    }
    while(gets(w))
    {
        cout<<m[w]<<endl;
    }
    return 0;
}