题干:
After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.
Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.
Please help Bessie determine all of the barns that would be suitable to disconnect.
Input
* Line 1: A single integer, N. The barns are numbered 1..N.
* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.
Output
* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".
Sample Input
10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8
Sample Output
3
8
Hint
INPUT DETAILS:
The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.
OUTPUT DETAILS:
If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).
题目大意:
给一棵n个结点的树。求去掉哪个点能使得剩下的每个连通子图的节点数不超过n/2.输出满足条件的点,如果有多个这样的点,则升序输出。
输入:第一个表示有n个结点,接下来n-1行每行两个值,表示这两个结点相连接。
解题报告:
树形dp。(跟树的重心挺像,类似的方法dp就行了)
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 2e5 + 5;
vector<int> vv[MAX];
int dp[MAX],sum[MAX],n;
int dfs(int cur,int root) {
dp[cur] = 1, sum[cur] = 1;
int up = vv[cur].size();
for(int i = 0; i<up; i++) {
int v = vv[cur][i];
if(v == root) continue;
int tmp = dfs(v,cur);
sum[cur] += tmp;
dp[cur] = max(dp[cur],tmp);
}
dp[cur] = max(dp[cur],n - sum[cur]);
return sum[cur];
}
int main()
{
while(~scanf("%d",&n)) {
for(int i = 1; i<=n; i++) vv[i].clear(),dp[i]=1;
for(int i = 1; i<=n-1; i++) {
int x,y;
scanf("%d%d",&x,&y);
vv[x].pb(y);
vv[y].pb(x);
}
dfs(1,-1);
int flag = 0;
for(int i = 1; i<=n; i++) {
if(dp[i]*2 <= n) {
flag = 1;
printf("%d\n",i);
}
}
if(flag == 0) puts("NONE");
}
return 0 ;
}
//14:34 - 14:40