Big Event in HDU

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2

10 1

20 1

3

10 1

20 2

30 1

-1

Sample Output

20 10

40 40

题意描述:

有n件物品已知n件物品的价值及它们的个数,将他们分成两部分A和B,使A、B两部分的价值尽可能的相等A不小于B。

解题思路:

将所有物品的总价值除以二即为背包的限制动态规划求解,得到的为B部分的价值。

#include<stdio.h>
int dp[255555],v[5010];
int maxx(int a,int b)
{
	if(a>=b)
		return a;
	else
		return b;
}
int main()
{
	int n,m,x,i,j,a,b;
	while(scanf("%d",&n))
	{
		if(n<0)
			break;
		m=0;
		x=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			m=m+a*b;
			for(j=x+1;j<=x+b;j++)
				v[j]=a;
			x=x+b;
		}
		for(i=0;i<=m/2;i++)
			dp[i]=0;
		for(i=1;i<=x;i++)
			for(j=m/2;j>=v[i];j--)
					dp[j]=maxx(dp[j],dp[j-v[i]]+v[i]);
			printf("%d %d\n",m-dp[m/2],dp[m/2]);
	}
	return 0;
}