Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smart kid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative. Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case. For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered 1, 2, . . . , N.

• ‘x not found’, if the marble with number x is not present. Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0

0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

 

题意:现有N个大理石,每个大理石上写了一个非负整数。首先把各数从小到大排序,然后回答Q个问题。每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上写着x。排序后的大理石从左到右编号为1~N。

思路:先sort一下,然后使用lower_bound查找是否存在x

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxNum = 10005;

int main() {
    int N, Q, qu,a[maxNum], kase = 0;
    while(~scanf("%d%d", &N, &Q)&& N) {
        printf("CASE# %d:\n", ++kase);
        for(int i = 0; i < N; i++) {
            scanf("%d", &a[i]);
        }
        sort(a, a + N);
        while(Q--) {
            scanf("%d", &qu);
            // 在已排序数组a中寻找x查找大于或等于x的第一个位置
            int p = lower_bound(a, a + N, qu) - a;
            if(a[p] == qu) {
                printf("%d found at %d\n", qu, p + 1);
            } else {
                printf("%d not found\n", qu);
            }
        }
    }
    return 0;
}