King's Order
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1283 Accepted Submission(s): 633
Problem Description
After the king's speech , everyone is encouraged. But the war is not over. The king needs to give orders from time to time. But sometimes he can not speak things well. So in his order there are some ones like this: "Let the group-p-p three come to me". As you can see letter 'p' repeats for 3 times. Poor king!
Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: "Let the group-p-p-p three come to me" can never come from the king. While the order:" Let the group-p three come to me" is a legal statement.
The general wants to know how many legal orders that has the length of n
To make it simple , only lower case English Letters can appear in king's order , and please output the answer modulo 1000000007
We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.
Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: "Let the group-p-p-p three come to me" can never come from the king. While the order:" Let the group-p three come to me" is a legal statement.
The general wants to know how many legal orders that has the length of n
To make it simple , only lower case English Letters can appear in king's order , and please output the answer modulo 1000000007
We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.
Input
The first line contains a number T(T≤10)——The number of the testcases.
For each testcase, the first line and the only line contains a positive number n(n≤2000).
For each testcase, the first line and the only line contains a positive number n(n≤2000).
Output
For each testcase, print a single number as the answer.
Sample Input
224
Sample Output
676456950hint:All the order that has length 2 are legal. So the answer is 26*26.For the order that has length 4. The illegal order are : "aaaa" , "bbbb"…….."zzzz" 26 orders in total. So the answer for n == 4 is 26^4-26 = 456950
Source
Recommend
wange2014
题意:构成连续的字母不超过3的是真的
思路:数位DP
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define MOD 1000000007
#define bug1 cout <<"bug1"<<endl
#define bug2 cout <<"bug2"<<endl
#define bug3 cout <<"bug3"<<endl
using namespace std;
typedef long long ll;
const int MAX_N=2e3+5;
int n;
int dp[MAX_N][30][5];
int dfs(int pos,int pre,int cnt){
if(pos==n+1) return 1;
if(dp[pos][pre][cnt]!=-1) return dp[pos][pre][cnt];
ll ans=0;
for(int i=1;i<=26;i++){
if(i!=pre) ans+=dfs(pos+1,i,1);
else{
if(cnt<3) ans+=dfs(pos+1,i,cnt+1);
}
}
ans%=MOD;
dp[pos][pre][cnt]=ans;
return ans;
}
int main(void){
int T;
cin >> T;
while(T--){
ll res=0;
scanf("%d",&n);
memset(dp,-1,sizeof(dp));
for(int i=1;i<=26;i++)
res+=dfs(2,i,1);
printf("%lld\n",res%MOD);
}
}