How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55161 Accepted Submission(s): 27377

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

也是一个裸题,和我上一个题思路基本是一样的,只是最后输出不一样,这题的他问最小需要的桌子数,其实就是并查集的根节点数,最后统计一下就行了。一发ac。

#include<iostream>
#define MAXSIZE 1002 
using namespace std;

typedef struct
{
	int data;
	int rank;
	int parent;
}UFStree;
void creat(UFStree ufs[], int n)
{
	for (int i = 1; i <= n; i++) {
		ufs[i].data = i;
		ufs[i].rank = 0;
		ufs[i].parent = i;
	}
}
int FIND_X(UFStree ufs[], int x) {
	return x == ufs[x].parent ? x : FIND_X(ufs, ufs[x].parent);
}
void UNION_x(UFStree ufs[], int x, int y) {
	int a = FIND_X(ufs, x);
	int b = FIND_X(ufs, y);
	if (ufs[a].rank > ufs[b].rank) {
		ufs[b].parent = a;
	}
	else {
		ufs[a].parent = b;
		if ((ufs[a].rank == ufs[b].rank) && a != b) {
			ufs[b].rank++;
		}
	}
}
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int a[MAXSIZE][2];
		int n, m;
		cin >> n >> m;
		for (int i = 0; i < m; i++) {
			cin >> a[i][0] >> a[i][1];
		}
		UFStree ufs[MAXSIZE];
		creat(ufs, n);
		for (int i = 0; i < m; i++) {
			UNION_x(ufs, a[i][0], a[i][1]);
		}
		int sum = 0;
		for (int i = 1; i <= n; i++) {
			if (ufs[i].parent == i)
				sum++;
		}
		cout << sum << endl;
	}
}