Monitor
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 163840/163840 K (Java/Others)
Total Submission(s): 71 Accepted Submission(s): 21
Problem Description
Xiaoteng has a large area of land for growing crops, and the land can be seen as a rectangle of n×m.
But recently Xiaoteng found that his crops were often stolen by a group of people, so he decided to install some monitors to find all the people and then negotiate with them.
However, Xiao Teng bought bad monitors, each monitor can only monitor the crops inside a rectangle. There are p monitors installed by Xiaoteng, and the rectangle monitored by each monitor is known.
Xiao Teng guess that the thieves would also steal q times of crops. he also guessed the range they were going to steal, which was also a rectangle. Xiao Teng wants to know if his monitors can see all the thieves at a time.
Input
There are mutiple test cases.
Each case starts with a line containing two integers n,m(1≤n,1≤m,n×m≤107) which represent the area of the land.
And the secend line contain a integer p(1≤p≤106) which represent the number of the monitor Xiaoteng has installed. This is followed by p lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m) ,meaning the lower left corner and upper right corner of the rectangle.
Next line contain a integer q(1≤q≤106) which represent the number of times that thieves will steal the crops.This is followed by q lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m),meaning the lower left corner and upper right corner of the rectangle.
Output
For each case you should print q lines.
Each line containing YES or NO mean the all thieves whether can be seen.
Sample Input
6 6 3 2 2 4 4 3 3 5 6 5 1 6 2 2 3 2 5 4 1 5 6 5
Sample Output
YES NO
Hint
In the picture,the red solid rectangles mean the monitor Xiaoteng installed, and the blue dotted rectangles mean the area will be stolen.
Source
先使用二维差分概念,处理获得监视器区域。然后进行前缀和处理,最后判断所给与区间大小和之前所处理内容的区间监视器的‘1’的数量大小相比较。相同就代表完全监视。
#include<bits/stdc++.h>
using namespace std;
int main() {
int n, m;
ios::sync_with_stdio(0);
while (cin >> n >> m) {
int **mp, **num;
mp = new int*[n + 1], num = new int*[n + 1];
for (int i = 0; i <= n + 1; i++)
mp[i] = new int[m + 1], num[i] = new int[m + 1];
for (int i = 0; i <= n + 1; i++) {
for (int j = 0; j <= m + 1; j++) {
mp[i][j] = 0; num[i][j] = 0;
}
}
int q;
cin >> q;
while (q--) {
int a, b, c, d;
cin >> a >> b >> c >> d;
if (a > c)swap(a, c);
if (b > d)swap(b, d);
mp[a][b]++;
mp[c + 1][d + 1]++;
mp[a][d + 1]--;
mp[c + 1][b]--;
}
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= m; j++) {
mp[i][j] += mp[i - 1][j] + mp[i][j - 1] - mp[i - 1][j - 1];
}
}
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= m; j++) {
if (mp[i][j] > 0)mp[i][j] = 1;
}
}
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= m; j++) {
num[i][j] = mp[i][j] + num[i - 1][j] + num[i][j - 1] - num[i - 1][j - 1];
}
}
cin >> q;
while (q--) {
int a, b, c, d;
cin >> a >> b >> c >> d;
if (a > c)swap(a, c);
if (b > d)swap(b, d);
int need = num[c][d] - num[c][b - 1] - num[a - 1][d] + num[a - 1][b - 1];
if (need == (c - a + 1)*(d - b + 1)) {
cout << "YES\n";
}
else {
cout << "NO\n";
}
}
}
return 0;
}