题目描述

The \(N\) cows (\(2 \leq N \leq 1,000\)) conveniently numbered \(1..N\) are grazing among the N pastures also conveniently numbered \(1..N\). Most conveniently of all, cow i is grazing in pasture i.

Some pairs of pastures are connected by one of \(N-1\)bidirectional walkways that the cows can traverse. Walkway i connects pastures \(A_i\)and \(B_i\) (\(1 \leq A_i \leq N; 1 \leq B_i \leq N\)) and has a length of \(L_i\) (\(1 \leq L_i \leq 10,000\)).

The walkways are set up in such a way that between any two distinct pastures, there is exactly one path of walkways that travels between them. Thus, the walkways form a tree.

The cows are very social and wish to visit each other often. Ever in a hurry, they want you to help them schedule their visits by computing the lengths of the paths between \(1 \leq L_i \leq 10,000\) pairs of pastures (each pair given as a query p1,p2 (\(1 \leq p1 \leq N; 1 \leq p2 \leq N\)).

POINTS: 200

\(N(2<=N<=1000)\)头奶牛,编号为\(1\)\(W\),它们正在同样编号为\(1\)\(N\)的牧场上行走.为了方 便,我们假设编号为i的牛恰好在第\(i\)号牧场上.

有一些牧场间每两个牧场用一条双向道路相连,道路总共有\(N - 1\)条,奶牛可以在这些道路 上行走.第i条道路把第Ai个牧场和第Bi个牧场连了起来(\(1 \leq A_i \leq N; 1 \leq B_i \leq N\)),而它的长度 是 \(1 \leq L_i \leq 10,000\).在任意两个牧场间,有且仅有一条由若干道路组成的路径相连.也就是说,所有的道路构成了一棵树.

奶牛们十分希望经常互相见面.它们十分着急,所以希望你帮助它们计划它们的行程,你只 需要计算出Q(1 < Q < 1000)对点之间的路径长度•每对点以一个询问\(p1,p2\) (\(1 \leq p1 \leq N; 1 \leq p2 \leq N\)). 的形式给出.

输入输出格式

输入格式:

  • Line 1: Two space-separated integers: \(N\) and \(Q\)

  • Lines 2..N: Line i+1 contains three space-separated integers: \(A_i, B_i\), and \(L_i\)

  • Lines \(N+1..N+Q\): Each line contains two space-separated integers representing two distinct pastures between which the cows wish to travel: \(p1\) and \(p2\)

输出格式:

  • Lines \(1..Q\): Line i contains the length of the path between the two pastures in query \(i\).

输入输出样例

输入样例#1:

4 2 
2 1 2 
4 3 2 
1 4 3 
1 2 
3 2 

输出样例#1:

2 
7 

说明

Query \(1\): The walkway between pastures \(1\) and \(2\) has length \(2\).

Query \(2\): Travel through the walkway between pastures \(3\) and \(4\), then the one between \(4\) and 1, and finally the one between \(1\) and \(2\), for a total length of \(7\).

思路:题意就是让你求树上两点之间的距离,我们可以先求出这两个点的\(LCA\),然后发现它们之间的距离其实就是这两个点到根结点距离的和减去两倍的它们的\(LCA\)到根结点的距离。

代码:

#include<cstdio>
#include<algorithm>
#define maxn 1007
using namespace std;
int n,m,head[maxn],d[maxn],f[maxn][22],num,dis[maxn];
struct node {
  int v,w,nxt;
}e[maxn<<1];
inline void ct(int u, int v, int w) {
  e[++num].v=v;
  e[num].w=w;
  e[num].nxt=head[u];
  head[u]=num;
}
void dfs(int u, int fa) {
  for(int i=head[u];i;i=e[i].nxt) {
    int v=e[i].v;
    if(v!=fa) {
      f[v][0]=u;
      d[v]=d[u]+1;
      dis[v]=dis[u]+e[i].w;
      dfs(v,u);
    }
  }
}
inline int lca(int a, int b) {
  if(d[a]>d[b]) swap(a,b);
  for(int i=20;i>=0;--i) 
  if(d[a]<=d[b]-(1<<i)) b=f[b][i];
  if(a==b) return a;
  for(int i=20;i>=0;--i)
  if(f[a][i]!=f[b][i]) a=f[a][i],b=f[b][i];
  return f[a][0];
}
int main() {
  scanf("%d%d",&n,&m);
  for(int i=1,u,v,w;i<n;++i) {
    scanf("%d%d%d",&u,&v,&w);
    ct(u,v,w);ct(v,u,w);
  }
  dfs(1,0);
  for(int j=1;j<=20;++j)
  for(int i=1;i<=n;++i)
  f[i][j]=f[f[i][j-1]][j-1];
  for(int i=1,u,v;i<=m;++i) {
    scanf("%d%d",&u,&v);
    printf("%d\n",dis[u]+dis[v]-2*dis[lca(u,v)]);
  }
  return 0;
}