Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题意:

给我们一个文本串和模式串,计算模式串有多少和文本串相等。

思路:

用kmp算法,暴力的话肯定会超时,所以写个kmp的模板,求next数组,然后再求有多少个数,不会的可以先去看看kmp算法。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e+6 + 10;
char str[maxn], mo[maxn];
int Next[maxn];
void GetNext() {
    int i = 0, j = -1, len = strlen(mo);
    while (i < len) {
        if (j == -1 || mo[j] == mo[i]) Next[++i] = ++j;
        else j = Next[j];
    }
}
int kmp() {
    int j = 0, i = 0, ans = 0, len1 = strlen(str), len2 = strlen(mo);
    while (i < len1) {
        if (j == -1 || mo[j] == str[i]) {
            i++;
            j++;
        } else j = Next[j];
        if (j == len2) ans++;
    }
    return ans;
}
int main() {
    ios::sync_with_stdio(false);
    int t;
    scanf("%d", &t);
    while (t--) {
        scanf("%s%s", mo, str);
        Next[0] = -1;
        GetNext();
        printf("%d\n", kmp());
    }
    return 0;
}