题目链接
For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2… N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2… N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1… Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0

题意:
给你N个奶牛,有每N个奶牛有一个高度,让你找出再Q个区间里每个区间里的奶牛最大值与最小值的差的值是多少?
解题思路:
一开始想着暴力,但时间复杂度想想就觉得太大了;
然后,用线段树区间求最大最小值即可,然后,发现还有一种方法就是RMQ;

#include<iostream>
#include<cstdio>
using namespace std;
const int N=5e5+10;
int mmp[N];
int n,m,x,y,a[N],f[N][20],g[N][20];
void RNQ()
{
    mmp[1]=0;
    for(int i=2;i<N;i++)
      mmp[i]=mmp[i-1]+!(i&(i-1));
    for(int i=1;i<=n;i++)
      f[i][0]=g[i][0]=a[i];
    for(int j=1;(1<<j)<=n;j++)
      for(int i=1;i+(1<<j)-1<=n;i++)
      {
          f[i][j]=max(f[i][j-1],f[i+(1<<j-1)][j-1]);
          g[i][j]=min(g[i][j-1],g[i+(1<<j-1)][j-1]);
      }
}
int getmax(int l,int r)
{
    int k=mmp[r-l+1];
    return max(f[l][k],f[r-(1<<k)+1][k]);
}
int getmin(int l,int r)
{
    int k=mmp[r-l+1];
    return min(g[l][k],g[r-(1<<k)+1][k]);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
          scanf("%d",&a[i]);
        RNQ();
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            printf("%d\n",getmax(x,y)-getmin(x,y));
        }
    }
    return 0;
}