Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题意:给出几种钱,用美元去换成别的钱,最后再换回美元,是否手里的美元比兑换前多,如果多输出Yes,否则输出 No

题解:通过SPFA算法求正环问题,模板题。。。。。详细解释看代码。

 

#include <iostream>
#include <cstring>
#include <map>
#include <queue>
using namespace std;
const int MAX = 1000;
int tot,flag;
struct hh{
	int to,nt;
	double w;
}a[MAX];
int vis[MAX],head[MAX];
double dis[MAX];//别忘了是double类型的,因为汇率是小数啊啊啊!
void init(){
	memset(head,-1,sizeof(head));
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	tot=0;
	flag=0;
}
void add(int u,int v,double w){//建图模板
	a[tot].to=v;
	a[tot].w=w;
	a[tot].nt=head[u];
	head[u]=tot++;
}
void spfa(int s){
	queue<int> q;
	q.push(s);
	dis[s]=1;//不要忘了赋值为1,因为一开始是1美元
	while(!q.empty()){
		int x=q.front();
		q.pop();
		vis[x]=0;//这里需要重新标记为0,表示作为小菜的我没看懂
		for (int i = head[x];~i;i = a[i].nt){
			int y=a[i].to;
			if(dis[y]<dis[x]*a[i].w){
				dis[y]=dis[x]*a[i].w;
				if(dis[s]>1){//判断是否为正环,也就是一开始的钱是否大于1
					flag=1;
					return;
				}
				if(!vis[y]){//如果没标记,就放到队列里面
					q.push(y);
					vis[y]=1;
				}
			}
		}
	}
}
int main(){
	int num=1;
	int n;
	while(cin >> n,n){
		init();//别忘了初始化
		map<string,int> mp;
		int cnt=1;
		for (int i = 0; i < n;i++){
			string s;
			cin >> s;
			mp[s]=cnt++;//把字符串变成整型,方便建图
		}
		int m;
		cin >> m;
		for (int i = 0; i < m;i++){
			string u,v;
			double w;
			cin >> u >> w >> v;
			add(mp[u],mp[v],w);//建图
		}
		spfa(1);
        if(flag==1) cout << "Case "<< num++ << ": Yes" << endl;
        else cout << "Case "<< num++ << ": No" << endl;;
	}
	return 0;
}