Description
对于一个1-N的排列(ai),每次你可以交换两个数ax与ay(x<>y),代价为W(ax)+W(ay) 若干次交换的代价为每次交换的代价之和。请问将(ai)变为(bi)所需的最小代价是多少。
Input
第一行N。第二行N个数表示wi。第三行N个数表示ai。第四行N个数表示bi。 2<=n<=1000000 100<=wi<=6500 1<=ai,bi<=n ai各不相等,bi各不相等 (ai)<>(bi) 样例中依次交换数字(2,5)(3,4)(1,5)
Output
一个数,最小代价。
Sample Input
6
2400 2000 1200 2400 1600 4000
1 4 5 3 6 2
5 3 2 4 6 1
Sample Output
11200
解题方法: 可以发现这道题和POJ3270很类似,唯一的区别就是这个置换的目标装态是直接给了,并没有要求按照升序排列,所以我们稍微转化一下就可以套用那个题目的方法了,如何转化呢?观察样例可以发现
1 4 5 3 6 2
5 3 2 4 6 1
样例中有三个轮换(5,2,1)(4,3)(6) 这里只的是数不是位置,当然如果改成位置的话就是(1,3,6)(2,4) (5)。然后像poj 3270 那样搞就可以了。
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn = 1000010;
int n, a[maxn], pos[maxn], vis[maxn];
LL w[maxn], MIN;
int main(){
scanf("%d", &n);
MIN = 1e9;
for(int i = 1; i <= n; i++) scanf("%lld", &w[i]), MIN = min(MIN, 1LL*w[i]);
for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
for(int i = 1; i <= n; i++){
int x; scanf("%d", &x); pos[x] = i;
}
LL ans = 0;
for(int i = 1; i <= n; i++){
if(!vis[i]){
int l = i;
LL curmin = 1e9;
LL cnt = 0;
LL sum = 0;
while(!vis[l]){
cnt++;
curmin = min(curmin, w[a[l]]);
sum += w[a[l]];
vis[l] = 1;
l = pos[a[l]];
}
if(cnt == 1) continue; //单个元素不用交换
ans += min(sum + 1LL * (cnt - 2) * curmin, sum + 1LL * curmin + 1LL * (cnt + 1) * MIN);
}
}
cout << ans << endl;
return 0;
}