矩阵快速幂求斐波那契数列

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

#include<cstdio>
#include<cstring>
using namespace std;
const int mod=10000;
struct mat{
	long long a[3][3];
};
mat operator*(mat x,mat y){
	mat ans;
	memset(ans.a,0,sizeof(ans.a));
	for(int i=1;i<=2;i++){
		for(int j=1;j<=2;j++){
			for(int k=1;k<=2;k++){
				ans.a[i][j]=(ans.a[i][j]+x.a[i][k]*y.a[k][j])%mod;
			}
		}
	}
	return ans;
}
mat ksm(mat x,int n){
	mat s;
	for(int i=1;i<=2;i++){
		for(int j=1;j<=2;j++){
			if(i==j) s.a[i][j]=1;
			else s.a[i][j]=0;
		}
	}
	while(n){
		if(n&1) s=s*x;
		x=x*x;
		n>>=1;
	}
	return s;
}
int main(){
	int n;
	mat a;
	a.a[1][1]=a.a[1][2]=a.a[2][1]=1;
	a.a[2][2]=0;
	while(scanf("%d",&n)){
		if(n==-1) break;
		mat f=ksm(a,n);
		printf("%lld\n",f.a[1][2]); 
	}
	return 0;
}