给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL
#include<bits/stdc++.h>
using namespace std;
int main(){
	char a[10005];
	cin>>a;
	int t1=0,t2=0,t3=0,t4=0;
	
	for(int i=0;i<=strlen(a);i++){
		if(a[i]=='G'||a[i]=='g')
			t1++;
		if(a[i]=='P'||a[i]=='p')
			t2++;
		if(a[i]=='L'||a[i]=='l')
			t3++;
		if(a[i]=='T'||a[i]=='t')
			t4++;
	}
	while(t1||t2||t3||t4){
		if(t1){
			cout<<"G";
			t1--;
		}
		if(t2){
			cout<<"P";
			t2--;
		}
		if(t3){
			cout<<"L";
			t3--;
		}
		if(t4){
			cout<<"T";
			t4--;
		}
	}
	cout<<endl;
	return 0;
}