Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:

给定一个正整数n,请编写一个程序来寻找n的一个非零的倍数m,这个m应当在十进制表示时每一位上只包含0或者1。你可以假定n不大于200且m不多于100位。 
提示:本题采用Special Judge,你无需输出所有符合条件的m,你只需要输出任一符合条件的m即可。

解题思路:

不要被不超过100位吓到了,可能就是因为这一句话就把你吓到了,如果说时不超过long long 呢?那是不是就可以枚举了。反正是从1开始,接下来不是是10,就是11,然后是 100 101 110 111.....,其实这道题的结果就是在long long范围内的。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
#include <algorithm>

using namespace std;
typedef long long LL;

LL bfs(int x)
{
    queue<LL> que;
    que.push(1);
    while(!que.empty())
    {
        LL num = que.front();   que.pop();
        if(num % x == 0)
            return num;
        que.push(num * 10);
        que.push(num * 10 + 1);
    }
    return -1;
}

int main()
{
    int n;
    while(scanf("%d", &n), n)
    {
        printf("%lld\n", bfs(n));
    }


    return 0;
}