Description

  监狱有连续编号为1…N的N个房间,每个房间关押一个犯人,有M种宗教,每个犯人可能信仰其中一种。如果
相邻房间的犯人的宗教相同,就可能发生越狱,求有多少种状态可能发生越狱
Input

  输入两个整数M,N.1<=M<=10^8,1<=N<=10^12
Output

  可能越狱的状态数,模100003取余
Sample Input
2 3
Sample Output
6
HINT

  6种状态为(000)(001)(011)(100)(110)(111)

解题思路: 首先没有限制的情况下,方案数就是m^n,然后有限制的话,第一个人取m个,那么他后边的人全都只能(m - 1)个,方案数就是m*(m-1)^(n-1),两个做差,就是答案了。

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const LL mod = 100003;
LL powmod(LL a, LL n){
    LL res = 1;
    while(n){
        if(n&1) res = res * a % mod;
        a = a * a % mod;
        n >>= 1;
    }
    return res;
}
int main(){
    LL n, m;
    scanf("%lld%lld", &m, &n);
    LL ans = (powmod(m, n) - (m*powmod(m-1, n-1)%mod) + mod) % mod;
    printf("%lld\n", ans);
}