POJ1426传送门

Find The Multiple

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111
题目大意:给定一个正整数n,请编写一个程序来寻找n的一个非零的倍数m,这个m应当在十进制表示时每一位上只包含0或者1。你可以假定n不大于200且m不多于100位。
提示:本题采用Special Judge,你无需输出所有符合条件的m,你只需要输出任一符合条件的m即可。

== 要特别注意的是本题测试采用的是special judge,这样也就大大的降低了我们写题的难度,也就是说我们只需要输出一组合法的数据就可以了,那么我们考虑一个问题每一位上只包含0或1是什么样的数?很容易就能想到 这个数可以是1的十倍或者十倍加一,那么接下来的代码实现就容易的多了==、

AC代码

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
int main()
{
    int n;
    while(cin >> n && n) //一定要记得判断n!= 0否则会RE
    {


        int ans = 1;
        queue<long long> q;
        q.push(ans);
        while(!q.empty())
        {
            long long sum = q.front();
            q.pop();
            if(sum % n == 0){
             cout << sum << endl;
             break;
             }

             else
             {
                 q.push(sum * 10);
                 q.push(sum * 10 + 1);
             }
        }
    }
}

原创转载请注明出处