算法训练 关联矩阵  
时间限制:1.0s   内存限制:512.0MB
    
问题描述
  有一个n个结点m条边的有向图,请输出他的关联矩阵。
输入格式
  第一行两个整数n、m,表示图中结点和边的数目。n<=100,m<=1000。
  接下来m行,每行两个整数a、b,表示图中有(a,b)边。
  注意图中可能含有重边,但不会有自环。
输出格式
  输出该图的关联矩阵,注意请勿改变边和结点的顺序。
样例输入
5 9
1 2
3 1
1 5
2 5
2 3
2 3
3 2
4 3
5 4
样例输出
1 -1 1 0 0 0 0 0 0
-1 0 0 1 1 1 -1 0 0
0 1 0 0 -1 -1 1 -1 0
0 0 0 0 0 0 0 1 -1
0 0 -1 -1 0 0 0 0 1

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#define for(i,x,n) for(int i=x;i<n;i++)
#define ll long long int

using namespace std;

int a[105][1005]={0};

int main()
{
    int m,n;
    int x,y;
    scanf("%d %d",&n,&m);
    for(i,0,m){
        scanf("%d %d",&x,&y);
        a[x][i]=1;
        a[y][i]=-1;
    }
    for(i,1,n+1){
        for(j,0,m){
            printf("%d ",a[i][j]);
        }
        printf("\n");
    }
    return 0;
}