problem description

link:https://vjudge.net/problem/UVA-340

description:
MasterMind is a game for two players. One of them, Designer, selects a secret(秘密的) code. The other, Breaker,
tries to break it. A code is no more than a row of colored dots(圆点) 《no more than 只是,仅仅 | a row of 一排》. At the beginning of a game, the players
agree upon《agree upon对。。。获得一致意见》 the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After
each guess Designer gives a hint(暗示,线索), stating to what extent(程度) the guess matches his secret code.

In this problem you will be given a secret code s1 … sn and a guess g1 … gn, and are to determine
the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strong
when i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent when
i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise(成对发生的)
independent.

Designer chooses an independent set M of matches for which the total number of matches and the
number of strong matches are both maximal(最大的). The hint then consists of the number of strong followed
by the number of weak matches in M. Note that these numbers are uniquely(独特的) determined by the secret
code and the guess. If the hint turns out to be (n, 0), then the guess is identical(完全相同的) to the secret code.

Input
The input will consist of data for a number of games. The input for each game begins with an integer
specifying N (the length of the code). Following these will be the secret code, represented as(被。。描绘成) N integers,

which we will limit to the range (范围)1 to 9. There will then follow an arbitrary(任意的) number of guesses, each
also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be
N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a
new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would
normally be specified). The maximum value for N will be 1000

Output
The output for each game should list the hints that would be generated for each guess, in order, one hint
per line. Each hint should be represented as a pair of integers enclosed(装入) in parentheses and separated by
a comma. The entire list of hints for each game should be prefixed(前缀) by a heading indicating the game
number; games are numbered sequentially starting with 1. Look at the samples below for the exact
format.

Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)


analysis


题目大概意思:给定答案序列和用户猜的序列,统计有多少数字位置正确(A),有多少数字在两个序列都出现过但位置不正确(B)
analysis:
直接统计A,
方法1:求B,对于每个数字(1–9),统计二者出现的次数c1,c2,
则min(c1 , c2)就是该数字对B的贡献。在减去A
方法2:
求B,还可以用一个标记数组,猜中就标记一下,对于两种方法,时间复杂度都是O(n^2)

但是个人觉得,方法1的想法还是很好的


code


#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 1005;
int a[maxn],b[maxn]; //a存答案,b存猜的
int n;
int main()
{
    int Case = 0;
    while(scanf("%d",&n)==1 && n)
    {
        for(int i=0; i<n; ++i)
            cin >> a[i];
        printf("Game %d:\n",++Case);
        for(int k=1;; ++k)
        {
            int A=0,B=0;
            for(int i=0; i<n; ++i)
            {
                cin >> b[i];
                if(a[i]==b[i])
                    A++;
            }
            if(!b[0])
                break;
            for(int i=1; i<=9; ++i)
            {
                int c1=0,c2=0;
                for(int j=0; j<n; ++j)
                {
                    if(a[j]==i)
                        c1++;
                    if(b[j]==i)
                        c2++;
                }
                if(c1<c2)
                    B += c1;
                else
                    B += c2;
            }

            printf(" (%d,%d)\n",A,B-A);
        }
    }
    system("pause");
    return 0;
}