Halloween treats
Time Limit: 2000MS Memory Limit: 65536K
Special Judge
Description
Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year’s experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.
Your job is to help the children and present a solution.
Input
The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , … , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.
The last test case is followed by two zeros.
Output
For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print “no sweets” instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.
Sample Input
4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0
Sample Output
3 5
2 3 4
思路:
鸽巢原理,因为邻居数大于小孩数,所以无论邻居的糖果怎样发放,还是拿到的糖果必定有一个可以可能是可以平分的,和POJ 2356思路一样,写过一遍,我就不写了这里点击题解
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1000010;
int book[maxn];
int main() {
ios::sync_with_stdio(false);
int n, m;
while (scanf("%d %d", &n, &m) != EOF && n + m) {
memset(book, -1, sizeof(book));
int l = 0, r = 0, x;
long long sum = 0;
book[0] = 0;
for (int i = 1; i <= m; i++) {
scanf("%d", &x);
sum += (long long)x;
int temp = sum % n;
if (book[temp] == -1) book[temp] = i;
else {
l = book[temp];
r = i;
}
}
for (int i = l + 1; i <= r; i++) {
if (i != l + 1) printf(" ");
printf("%d", i);
}
printf("\n");
}
return 0;
}