题干:

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

题目大意:

这个题的意思就是给n个数,求这n个数的子序列中不算重复的数的和。
比如第二个样例他的子序列就是{2},{2,3},{2,3,3},{3},{3,3},{3};
但每个子序列中重复的元素不被算入,所以他们的总和就是2+5+5+3+3+3=21;

解题报告:

 计算每个位置上的值出现的次数,为了避免重复计算,我们只在他认为他对他后面的数组有效,当后面的数组要用到前面的值的时候,这个数组是无效的。所以我们只需要记录每个数字出现的位置就可以了。然后直接暴力统计  包含这个位置的数值 的 子数组个数就好了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 1e6 + 5;
int pos[MAX];
int main()
{
	int t,n;
	cin>>t;
	while(t--) {
		scanf("%d",&n);
		memset(pos,0,sizeof pos);
		ll ans = 0;
		for(int x,i = 1; i<=n; i++) {
			scanf("%d",&x);
			ans += (i-pos[x]) * (n-i+1LL)*x;
			pos[x] = i;
		}
		printf("%lld\n",ans);
	}


	return 0 ;
}