斐波那契问题
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
思路:
7 11 18 29 47 76 123 199 322 521 843 1364 2207 3571 5578...
我们发现 2,6,10..可以被3整除。遇到这样的题,一般的思维会想着先把数列写出来,然后进行作出判断,但是,看他的数据量就应该想想是否是道规律题。
#include<stdio.h>
int main(){
int n ;
while(scanf("%d",&n)!=EOF){
if(n%4 == 2){
printf("yes\n");
}
else{
printf("no\n");
}
}
return 0;
}