题目描述:

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入描述:

The first line consist only one integer N, indicates N cases follows. 
In each case, there are two lines, the first line gives the string A, 
length (A) <= 10, and the second line gives the string B, length (B) <= 1000.
 And it is guaranteed that B is always longer than A.

输出描述:

For each case, output a single line consist a single integer,
 tells how many times do B appears as a substring of A.

样例输入:

3
11
1001110110
101
110010010010001
1010
110100010101011 

样例输出:

3
0
3 

题目解析:

本题题意为在一个字符串ss中寻找子串s出现的次数

测试地址:测试点击此处

本题代码:

#include<iostream>
#include<string>
using namespace std;
void deal(string ss,string s)
{
	int sum=0,p;
	while(1)
	{
		p=ss.find(s);
		if(p==-1)
		break;
		sum++;
		ss.replace(p,1,"q");//利用替换来防止重复查找
	}
	cout<<sum<<endl;
}
int main()
{
	int n;
	string s,ss;
	cin>>n;
	while(n--)
	{
		cin>>s>>ss;
		deal(ss,s);
	}
return 0;
}