In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another.

Given a descri_ption of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way.

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample:

One visualization of the paths is:

1   2   3
   +---+---+  
       |   |
       |   |
 6 +---+---+ 4
      / 5
     / 
    / 
 7 +

Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions.

1   2   3
   +---+---+  
   :   |   |
   :   |   |
 6 +---+---+ 4
      / 5  :
     /     :
    /      :
 7 + - - - - 

Check some of the routes:
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
Every pair of fields is, in fact, connected by two routes.

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

 

边-双连通分量,含重边。

自环对点/边双连通分量都没有影响,重边对点双无影响,对边双有影响,需要在刘汝佳模板基础上小改一下。

一个Edge-BCC内的点可以等效成一个点,因为其互相有两条边不相同路径。

故缩点后的图变为一颗树,树边就是原图的所有桥。

有一个定理:使树变为边双联通图的最少加边数是(广义叶子(度为1的点)数+1)/2.

就是把叶子两两相连,叶子数为奇数有一个无法配对叶子连到结点上。

#include<cstdio>
#include<vector>
#include<iostream>
using namespace std;
#define maxn (5000+100)

int n,m;
struct Edge{
	int from,to;
};
vector<int> G[maxn];
vector<Edge> edges;
int pre[maxn],dfs_clock;
bool isbridge[maxn*2];
int Ebccno[maxn],Ebcc_cnt;
int degree[maxn];

int dfs(int u,int fa)
{
	int lowu=pre[u]=++dfs_clock;
	int child=0;
	for(int i=0;i<G[u].size();i++)
	{
		int v=(edges[G[u][i]].to!=u?edges[G[u][i]].to:edges[G[u][i]].from);
		if(!pre[v])
		{
			child++;
			int lowv=dfs(v,G[u][i]);
			lowu=min(lowu,lowv);
			if(lowv>pre[u])isbridge[G[u][i]]=1;
		}
		else if(pre[v]<pre[u]&&G[u][i]!=fa)
		{
			lowu=min(lowu,pre[v]);
		}
	}
	return lowu;
}

void dfs2(int u)
{
	Ebccno[u]=Ebcc_cnt;
	for(int i=0;i<G[u].size();i++)
	{
		int v=(edges[G[u][i]].to!=u?edges[G[u][i]].to:edges[G[u][i]].from);
		if(!Ebccno[v]&&!isbridge[G[u][i]])dfs2(v);
	}
}

int main()
{
//	freopen("input.in","r",stdin);
	int a,b;
	scanf("%d%d",&n,&m);
	while(m--)
	{
		scanf("%d%d",&a,&b);
		edges.push_back((Edge){a,b});
		G[a].push_back(edges.size()-1);
		G[b].push_back(edges.size()-1);
	}
	for(int i=1;i<=n;i++)if(!pre[i])dfs(i,-1);
	for(int i=1;i<=n;i++)if(!Ebccno[i])Ebcc_cnt++,dfs2(i);

	for(int i=0;i<edges.size();i++)if(isbridge[i])
		degree[Ebccno[edges[i].from]]++,degree[Ebccno[edges[i].to]]++;
	int num=0;
	for(int i=1;i<=Ebcc_cnt;i++)if(degree[i]==1)num++;
	cout<<(num+1)/2<<endl;
	return 0;
}