题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output

10
20
30

Problem solving report:

Description: 要在一个走廊搬桌子,从第s号房间到第t号房间,可以多组一起搬,因为走廊的地方有限,不能同时搬重合的,例如10-20,30-40可以一起搬,但是10-20,15-30不能同时搬,求总计用多少时间能搬完桌子(最短时间)。
Problem solving:
①方法一:我们可以直接遍历s到t之间的每个走廊总共要用多少次,求这些走廊最大的重复量是多少。那些不重复的可以在一块搬,而那些重复的就需要下一次再搬。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int main()
{
    int tt, t, n, s, a[220], max;
    scanf("%d", &tt);
    while (tt--)
    {
        scanf("%d", &n);
        memset(a, 0, sizeof(a));
        max = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d%d", &s, &t);
            if (s > t)
                swap(s, t);
            for (int j = (s + 1) / 2; j <= (t + 1) / 2; j++)//(s+1)/2表示第几个走廊空间,例如,房间1门前的是1,房间3门前的是2...
            {
                a[j]++;
                if (max < a[j])
                    max = a[j];
            }
        }
        printf("%d\n", max * 10);
    }
    return 0;	
}

②方法二:可以用贪心中的不相交区间来做,我们可以把每次不相交的标记一下,统计一下搬几次就行了。

#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
struct edge {
    int left, right;
}e[205];
bool cmp(edge a, edge b) {
    return a.left < b.left;
}
int main()
{
    int tt, n, s, t, ans, right, vis[205];
    scanf("%d", &tt);
    while (tt--)
    {
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
        {
            scanf("%d%d", &s, &t);
            if (s > t)
                swap(s, t);
            e[i].left = (s + 1) / 2;//每个房间门前走廊的编号,房间1和房间2是一样的
            e[i].right = (t + 1) / 2;
        }
        ans = 0;
        sort(e, e + n, cmp);
        memset(vis, 0, sizeof(vis));
        for (int i = 0; i < n; i++)
        {
            if (vis[i])//已经搬过了
                continue;
            ans++;//又开始一次
            vis[i] = 1;//标记一下
            right = e[i].right;
            for (int j = i + 1; j < n; j++)
            {
                if (!vis[j] && right < e[j].left)//是否相交
                {
                    vis[j] = 1;
                    right = e[j].right;
                }
            }
        }
        printf("%d\n", ans * 10);
    }
    return 0;
}