Expedition

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input
* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10
Sample Output
2
Hint
INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
一群牛抓住一辆卡车冒险去丛林深处探险。由于司机比较穷,奶牛很不幸地跑过一块石头,刺穿卡车的油箱。卡车现在每行驶一单位的距离就泄露一单位燃料。

要修理卡车,牛需要开车到最近的城镇(不超过1000000个单位远)下一个漫长的,曲折的道路。在这条道路上,在城镇和当前位置的卡车,有N(1 < N = N = 10000)燃料站的奶牛可以停止获得额外的燃料(1 ..单位在每个站)。

丛林对于人类来说是一个危险的地方,对奶牛来说尤其危险。因此,奶牛想在到达城镇的路上尽可能地减少燃料的停靠。幸运的是,在他们的卡车上的燃料箱的容量是如此之大,实际上是没有限制的燃料量,它可以容纳。卡车目前L单位远离城市,有P单位的燃料(1 = P = P = 1000000)。

确定到达城镇所需的最低停靠点,或者奶牛根本无法到达城镇。


基本方法:贪心+优先队列

题意:以汽车要行驶距离L的路程,路上有n个加油站,车从起点出发,在起点时,车上有汽油容量为p,已知单位距离1,就会消耗汽油1,已知n个加油站距离终点的距离和各个加油站可以加的油量,然后问最少需要加多少次油可以到达终点,若不能到达终点,输出“-1”。


解析:按照贪心的思想,我们肯定是尽可能的把油用完了再加,但是每个加油站的加油量有区别,这样就不能简单的贪心了。我们可以这样看,由于不知道什么时候加最合适,所以我们可以先把那些途经的加油站的油量全部放到优先级队列里,到后来需要的时候再加上,就相当于是经过那个站的时候把油给加上了,效果是一样的。这样就可以了,每次加的都是油量最大的,所以最后的加油次数就是最少的。

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstdlib>
using namespace std;
struct node
{
    int dist,fuel;
}o[10000+10];
bool operator < (const struct node&a,const struct node&b)
{
    if(a.dist<b.dist)
    return true;
    return false;
}//重载大于运算符
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&o[i].dist,&o[i].fuel);
    }
    int l,p;
    cin>>l>>p;
    for(int i=0;i<n;i++)
    {
        o[i].dist = l - o[i].dist;
    }
    o[n].dist = l;
    o[n].fuel = 0;
    sort(o,o+n+1);
    int pos = p,ans = 0;//当前油箱储量
    priority_queue<int>q;
    for(int i=0;i<=n;i++)
    {
        while(!q.empty()&&pos<o[i].dist)
        {
            ans++;
            pos+=q.top();
            q.pop();
        }
        if(pos>=o[i].dist)
        {
            q.push(o[i].fuel);
        }
        else
        {
        cout<<"-1"<<endl;
        return 0;
        }

    }
    cout<<ans<<endl;
    return 0;
}