Oil Deposits

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23695 Accepted: 12303

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output

0
1
2
2

题目大意:给定一个nm的矩阵,矩阵仅有,@组成,要你求@的联通块,@上下左右斜线八个方向。
思路:
对每个元素遍历,找到一个@,把他联通的@全部改成 * ,然后联通块+1,类似染色的思想。。。
另外可以设置一个数组预先存好八个方向,然后之间调用数组的值就行了,这样简单一些。1a嘻嘻。。
代码:

#include<iostream>
using namespace std;

const int maxn=105;
char str[maxn][maxn];
int n,m;
int dir[8][2]={{-1,0},{1,0},{0,-1},{0,1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y){
	if(str[x][y]=='@'){
		str[x][y]='*'; 
	}
	for(int i=0;i<8;i++){
		int fx=x+dir[i][0];
		int fy=y+dir[i][1];
		if(str[fx][fy]=='@'&&fx>=0&&fx<=n&&fy>=0&&fy<=m){
			dfs(fx,fy);
		}
	}
}
int main(){
	while(scanf("%d%d",&n,&m)==2&&(n||m)){
		int ans=0;
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				scanf(" %c",&str[i][j]);
			}
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(str[i][j]=='@'){
					dfs(i,j);
					ans++;
				}
			}
		}
		cout<<ans<<endl;
	}
}