推荐博客:kmp算法详解

针对kmp算法的习题训练网址:https://blog.csdn.net/hpu2022/article/details/81812497

来看一道经典题目:

                              Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42846    Accepted Submission(s): 17687


 

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

 

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

 

 

Sample Output


6 
-1

题目大意:给出一个母串和一个子串,然后输出子串第一次出现在母串中的位置。

 

#include <stdio.h>
#include <string.h>
using namespace std;
const int MAXN = (int) 1e6 + 7;

int n, m;       // 母串和子串的长度
int t[MAXN];   // 子串
int s[MAXN];   // 母串
int next[MAXN];
void getNext(int length)
{
	memset(next, 0, sizeof(next));
	next[0] = -1;
	int j = 0;
	int k = -1;

	while(j < length)
	{
		if(k == -1 || t[j] == t[k])
		{
			next[++j] = ++k;
		}
		else
			k = next[k];
	}
}
int kmp()
{
    int i = 0;
    int j = 0;
    while(i < n && j < m)
    {
        if(s[i] == t[j])
            i++, j++;
        else if(j == -1)
            i++;
        else
            j = next[j];
    }
    if(j == m)
        return i - m + 1;
    else
        return -1;
}
int main()
{
    int num;
    scanf("%d", &num);
    while( num-- )
    {
        scanf("%d%d", &n, &m);
        for(int i=0; i<n; i++)
            scanf("%d", &s[i]);
        for(int i=0; i<m; i++)
            scanf("%d", &t[i]);
        getNext(m);
        printf("%d\n", kmp());

    }




	return 0;
}