人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39690    Accepted Submission(s): 26813


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 

Sample Input
2 3 12 6 6789 10000 0 0
 

Sample Output
8 984 1
 

Author
lcy
 

Source


题意:

如题目所描述。快速幂模版。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;

long long quickpow(long long m,long long n,long long k)  
{  
    long long b = 1;  
    while (n > 0)  
    {  
          if (n & 1)  
             b = (b*m)%k;  
          n = n >> 1 ;  
          m = (m*m)%k;  
    }  
    return b;  
}   

int main()
{
    int a,b;
    while(~scanf("%d%d",&a,&b)&&a&&b)
    {
        long long res=quickpow(a,b,1000);    
        printf("%lld\n",res);
    }
    return 0;    
}