开始呢这个题一看是多个点对点的,想用弗洛伊德做,超时,搜了题解 dijkstra 可以处理多点对一点的 还是没有好好理解dijkstra第一步初始化的作用,第一步从哪个点初始化,就是从哪个点出发==还得是潜下心debug啊~~而且dijkstra中每一步都是最优,完全可以处理多点对一点的问题

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
#include <iostream>
#include<cstdio>
#include<cstring>
#define MaxN 10010
#define MaxInt 2000000
using namespace std;
int map[MaxN][MaxN],dist[MaxN],start;
bool mark[MaxN];
int n,m,s,p,q,t,w,b,end,min1,minn,ww;
void dijkstra(int s)
{
     memset(mark,0,sizeof(mark));
     for(int i=1;i<=n;i++) dist[i]=map[s][i];
     mark[s]=1;dist[s]=0;
     int k;
     for(int i=1;i<n;i++)
     {
          minn=MaxInt;
          for(int j=1;j<=n;j++)
          {
               if(!mark[j]&&minn>dist[j])
               {
                    k=j;
                    minn=dist[j];
               }
          }
          if(minn==MaxInt) break;
          mark[k]=1;
          for(int j=1;j<=n;j++)
          {
               if(!mark[j]&&dist[j]>dist[k]+map[k][j])
               {
                    dist[j]=dist[k]+map[k][j];
               }
          }
     }
}
int main()
{
   // freopen("cin.txt","r",stdin);
    while(~scanf("%d%d%d",&n,&m,&s))
    {
         for(int i=1;i<=n;i++)
         {
              for(int j=1;j<=n;j++)
              {
                   map[i][j]=MaxInt;
              }
         }
         for(int i=0;i<m;i++)
         {
              scanf("%d%d%d",&p,&q,&t);
              if(t<map[q][p])
              map[q][p]=t;
         }
         dijkstra(s);
         min1=MaxInt;
         scanf("%d",&w);
         while(w--)
         {
              scanf("%d",&ww);
              if(min1>dist[ww]) min1=dist[ww];
         }
         if(min1!=MaxInt)
         printf("%d\n",min1);
         else printf("-1\n");
    }
    return 0;
}