hdu 1576

题目:

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。 每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2
1000 53
87 123456789

Sample Output

7922
6060

题解:

先了解一些概念:
费马小定理:ap−1≡1 (mod p) ,其中 gcd(a,p)=1 ,p为质数

逆元:对于a和p,若 a * inv(a) % p ≡ 1,则称inv(a)为a%p的逆元。p为质数

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll mod=9973;

ll poww(ll a,ll b)
{
   
	ll ans=1;
	ll base=a;
	while(b)
	{
   
		if(b&1!=0)ans=ans*base%mod;
		base=base*base%mod;
		b>>=1;
	}
	return ans%mod;
}
int main()
{
   
	int t;
	cin>>t;
	while(t--)
	{
   
		ll n,b;
		cin>>n>>b;
		//cout<<poww(2,3)<<endl;
		cout<<n*poww(b,mod-2)%mod<<endl;
	}
	return 0;

}