题目链接:http://bailian.openjudge.cn/practice/4116?lang=en_US
总时间限制: 1000ms 内存限制: 65536kB

描述

公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。 
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。 
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。

给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入

第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入 
1、两个整数代表N和M, (N, M <= 200). 
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#"代表墙壁。

输出

如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible"

样例输入

2
7 8
#@#####@
#@a#@@r@
#@@#x@@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@ 
13 40
@x@@##x@#x@x#xxxx##@#x@x@@#x#@#x#@@x@#@x
xx###x@x#@@##xx@@@#@x@@#x@xxx@@#x@#x@@x@
#@x#@x#x#@@##@@x#@xx#xxx@@x##@@@#@x@@x@x
@##x@@@x#xx#@@#xxxx#@@x@x@#@x@@@x@#@#x@#
@#xxxxx##@@x##x@xxx@@#x@x####@@@x#x##@#@
#xxx#@#x##xxxx@@#xx@@@x@xxx#@#xxx@x#####
#x@xxxx#@x@@@@##@x#xx#xxx@#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#xx@##@#@##xx@#@@x@x
x#x#@x@#x#@##@xrx@x#xxxx@##x##xx#@#x@xx@
#x@@#@###x##x@x#@@#@@x@x@@xx@@@@##@@x@@x
x#xx@x###@xxx#@#x#@@###@#@##@x#@x@#@@#@@
#@#x@x#x#x###@x@@xxx####x@x##@x####xx#@x
#x#@x#x######@@#x@#xxxx#xx@@@#xx#x#####@

样例输出

13
7

解题思路

题意:牢房里有墙(#),守卫(x)和道路(@),公主被关在牢房里位置为a,你的位置在r处,杀死一个守卫要一秒钟,每走一步要一秒钟,求最短时间救出公主,不能救出则输出:Impossible.
思路:BFS搜索,利用vis[x][y]保存到(x,y)的最短距离,剪枝一下,或者利用优先队列。

Accepted Code:

//二维计数
#include <bits/stdc++.h>
using namespace std;
const int MAXN = 205;
const int inf = 0x3f3f3f3f;
char mp[MAXN][MAXN];
int n, m, spt[MAXN][MAXN];
int dir[][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};
struct edge {
    int x, y;
    edge(int x_, int y_) : x(x_), y(y_) {}
};
void BFS(int x, int y) {
    spt[x][y] = 0;
    queue <edge> Q;
    Q.push(edge(x, y));
    while (!Q.empty()) {
        edge p = Q.front();
        Q.pop();
        for (int i = 0; i < 4; i++) {
            int tx = p.x + dir[i][0];
            int ty = p.y + dir[i][1];
            if (tx >= 0 && tx < n && ty >= 0 && ty < m && mp[tx][ty] != '#') {
                int t = spt[p.x][p.y] + 1;
                if (mp[tx][ty] == 'x')
                    t++;
                if (t < spt[tx][ty]) {
                    spt[tx][ty] = t;
                    Q.push(edge(tx, ty));
                }
            }
        }
    }
}
int main() {
    int t, ex, ey, sx, sy;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                spt[i][j] = inf;
                scanf(" %c", &mp[i][j]);
                if (mp[i][j] == 'r')
                    sx = i, sy = j;
                else if (mp[i][j] == 'a')
                    ex = i, ey = j;
            }
        }
        BFS(sx, sy);
        if (spt[ex][ey] < inf)
            printf("%d\n", spt[ex][ey]);
        else printf("Impossible\n");
    }
    return 0;
}
//优先队列
#include <bits/stdc++.h>
using namespace std;
const int MAXN = 205;
char mp[MAXN][MAXN];
int n, m, spt[MAXN][MAXN];
int dir[][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};
struct edge {
    int x, y, t;
    edge(int x_, int y_, int t_) : x(x_), y(y_), t(t_) {}
    bool operator < (const edge &s) const {
        return s.t < t;
    }
};
int BFS(int x, int y, int x_, int y_) {
    mp[x][y] = '#';
    priority_queue <edge> Q;
    Q.push(edge(x, y, 0));
    while (!Q.empty()) {
        edge p = Q.top();
        Q.pop();
        if (!(p.x != x_ || p.y != y_))
            return p.t;
        for (int i = 0; i < 4; i++) {
            int tx = p.x + dir[i][0];
            int ty = p.y + dir[i][1];
            if (tx >= 0 && tx < n && ty >= 0 && ty < m && mp[tx][ty] != '#') {
                int t = p.t + 1;
                if (mp[tx][ty] == 'x')
                    t++;
                mp[tx][ty] = '#';
                Q.push(edge(tx, ty, t));
            }
        }
    }
    return -1;
}
int main() {
    int t, ex, ey, sx, sy;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                scanf(" %c", &mp[i][j]);
                if (mp[i][j] == 'r')
                    sx = i, sy = j;
                else if (mp[i][j] == 'a')
                    ex = i, ey = j;
            }
        }
        int ans = BFS(sx, sy, ex, ey);
        if (~ans)
            printf("%d\n", ans);
        else printf("Impossible\n");
    }
    return 0;
}