D - Just another Robbery
Time Limit:4000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
LightOJ 1079
Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Output
For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
Case 1: 2
Case 2: 4
Case 3: 6

Hint

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That’s why he has only option, just to rob rank 2.

dp概率题,dp[i]表示抢i块钱不被抓的概率是多少
然后一直从sum循环到mone[i];如果dp[j-mone[i]]存在啦;
那么与p[i]相乘表示抢j钱不被抓的概率是多少
ac代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=100005;
int v[N],x[N],d[N];
ll n,c,a,b;
void f(ll t,ll x)
{
    double ans=sqrt(1.0*2*c*t+x*x);
    printf("%.3lf\n",ans);
}
int main()
{
    int T,t;
    cin>>T;
    while(T--){
        scanf("%lld%lld",&n,&c);
        for(int i=0;i<n;i++)
            scanf("%d%d%d",&v[i],&x[i],&d[i]);
            sort(v,v+n);
            cin>>t;
            for(int i=0;i<t;i++)
                {
                    scanf("%lld%lld",&a,&b);
                    f(a,v[b-1]);
                }
    }
    return 0;
}

心情不过,总感觉队友不是很认同我,算啦,随意;