Output
一个整数R
Sample Input
7
9
4
8
20
14
15
18
Sample Output
13
HINT
所求的Z序列为6,7,8,13,14,15,18.
R=13
论文题:https://wenku.baidu.com/view/20e9ff18964bcf84b9d57ba1.html
解题链接:http://blog.csdn.net/u011265346/article/details/46532421
//BZOJ 1367
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1000005;
int n, arr[maxn];
int tot=0;
int v[maxn], tr[maxn][2], dist[maxn], siz[maxn];
int root[maxn];
int l[maxn], r[maxn];
int Merge(int x, int y)
{
if(!x||!y) return x+y;
if(v[x]<v[y]) swap(x, y);
tr[x][1]=Merge(tr[x][1], y);
siz[x] = siz[tr[x][0]] + siz[tr[x][1]] + 1;
if(dist[tr[x][1]]>dist[tr[x][0]]) swap(tr[x][0], tr[x][1]);
dist[x]=dist[tr[x][1]]+1;
return x;
}
int top(int x){
return v[x];
}
int getsize(int x){
return siz[x];
}
void pop(int &x){
x=Merge(tr[x][0], tr[x][1]);
}
int newnode(int x){
v[++tot]=x;
siz[tot]=1;
tr[tot][1]=tr[tot][0]=dist[tot]=0;
return tot;
}
int main()
{
scanf("%d", &n);
for(int i=1; i<=n; i++) scanf("%d", &arr[i]), arr[i]-=i;
int cnt=0;
for(int i=1; i<=n; i++){
cnt++;
root[cnt]=newnode(arr[i]);
l[cnt]=r[cnt]=i;
while(cnt>1&&top(root[cnt])<top(root[cnt-1])){
cnt--;
root[cnt]=Merge(root[cnt], root[cnt+1]);
r[cnt]=r[cnt+1];
while(getsize(root[cnt])*2>r[cnt]-l[cnt]+2){
pop(root[cnt]);
}
}
}
long long ans=0;
for(int i=1; i<=cnt; i++){
int t=top(root[i]);
for(int j=l[i]; j<=r[i]; j++){
ans += abs(t-arr[j]);
}
}
printf("%lld\n", ans);
return 0;
}