Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights.
You are asked to help her by calculating how many weights are required.

Input
The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider “no solution” cases.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output
The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions.
You can measure dmg using x many amg weights and y many bmg weights.
The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition.
The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.
Sample Input
700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0
Sample Output
1 3
1 1
1 0
0 3
1 1
49 74
3333 1

这道题就是两边都可以放砝码,然后叫我们求出最小的砝码个数。

因为两边都可以放,所以我们使用拓展欧几里得的时候,为正代表放左边,为负代表放右边,然后再求出abs(x)+abs(y)的最小值,这个怎么算呢?

可以证明的是,当这两个绝对值相加最小,必定有一个为最下正整数,所以我们可以枚举两种答案,最后取一个最小值。

ac代码:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int a,b,c,x0,y0,res1,res2,res3,res4;
int ex_gcd(int a,int b,int &x,int &y)
{
	if(!b)
	{
		x=1;	y=0;	return a;
	}
	int d=ex_gcd(b,a%b,x,y);
	int t=x;	x=y;	y=t-y*(a/b);
	return d;
}
int main()
{
	while(cin>>a>>b>>c,a||b||c)
	{
		int d=ex_gcd(a,b,x0,y0);
		x0*=c/d;	y0*=c/d;
		res1=(x0%(b/d)+b/d)%(b/d);
		int t=res1-x0; t/=(b/d); res2=y0-t*a/d;
		
		res3=(y0%(a/d)+a/d)%(a/d);
		t=res3-y0;	t/=(a/d); res4=x0-t*b/d;
		if(abs(res1)+abs(res2)<abs(res3)+abs(res4))	cout<<abs(res1)<<' '<<abs(res2)<<endl;
		else	cout<<abs(res4)<<' '<<abs(res3)<<endl;
	}
	return 0;
}