Romantic

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy Xa + Yb = 1. If no such answer print “sorry” instead.

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

题意:

求出x, y为何值时,满足a * x + b * y = 1。

思路:

扩展欧几里得算法,首先就是算出x, y得值,然后因c = 1,所以当c % gcd = 0时,gcd = 1,所以x *= 1,由于gcd = 1, x得通解x + (b / gcd) * k=x + b * k,而x要大于0, 就有了x = (x % b + b) % b;, 已知了x,套公式就可以算出y了。

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long ll;
ll Exgcd(ll a, ll b, ll &x, ll &y) {
    if (b == 0) {
        x = 1;
        y = 0;
        return a;
    }
    ll g = Exgcd(b, a % b, x, y);
    ll t = x;
    x = y;
    y = t - a / b * y;
    return g;
}
int main() {
    ll a, b;
    while (scanf("%lld %lld", &a, &b) != EOF) {
        ll x, y;
        ll gcd = Exgcd(a, b, x, y);
        if (gcd != 1) printf("sorry\n");
        else {
            x = (x % b + b) % b;
            y = (1 - x * a) / b;
            printf("%lld %lld\n", x, y);
        }
    }
    return 0;
}