Description:

As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem’s difficulty is i. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1…ai are monotone decreasing or monotone increasing.
2: ai…an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems’ difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p.

Input:

Multiply test cases(less than 1000). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. (1≤n,p≤1018)

Output:

For each test case, output a single line indicating the answer.

Sample Input:

2 233
3 5

Sample Output:

2
1

Hint:

In the first case, both sequence {1, 2} and {2, 1} are legal.
In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1

题目链接

暴力跑出结果可发现规律 a n s = n p 2 ans=n^{p}-2 ans=np2

n n n p p p的数据范围很大,即使使用快速幂也会爆数据范围,所以要用到快速乘法。

快速乘法/幂 算法详解

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
#define mp make_pair
#define lowbit(x) (x&(-x))
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
typedef pair<ll,ll> PLL;
const int INF = 0x3f3f3f3f;
const int maxn = 4e6 + 5;
const int mod = 1e9 + 7;
const double eps = 1e-8;
const double pi = asin(1.0) * 2;
const double e = 2.718281828459;
bool Finish_read;
template<class T>inline void read(T &x) {
	Finish_read = 0;
	x = 0;
	int f = 1;
	char ch = getchar();
	while (!isdigit(ch)) {
		if (ch == '-') {
			f = -1;
		}
		if (ch == EOF) {
			return;
		}
		ch = getchar();
	}
	while (isdigit(ch)) {
		x = x * 10 + ch - '0';
		ch = getchar();
	}
	x *= f;
	Finish_read = 1;
};

ll QuickMul(ll a, ll b, ll p) {
	ll res = 0;
	while (b) {
		if (b & 1) {
			res = (res + a) % p;
		}
		a = (a + a) % p;
		b >>= 1;
	}
	return res;
}

ll QuickPow(ll a, ll b, ll p) {
	ll res = 1;
	while (b) {
		if (b & 1) {
			res = QuickMul(res, a, p) % p;
		}
		a = QuickMul(a, a, p) % p;
		b >>= 1;
	}
	return res;
}

int main(int argc, char *argv[]) {
#ifndef ONLINE_JUDGE
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
#endif
	ll n, p;
	while (~scanf("%lld %lld", &n, &p)) {
		if (n == 1) {
			if (p > 1) {
				printf("1\n");
			}
			else {
				printf("0\n");
			}
		}
		else {
			ll ans = QuickPow(2, n, p) - 2;
			while (ans < 0) {
				ans += p;
			}
			printf("%lld\n", ans);
		}
	}
#ifndef ONLINE_JUDGE
	fclose(stdin);
	fclose(stdout);
	system("gedit out.txt");
#endif
    return 0;
}