Bone Collector

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

题意描述:

有n个骨头,一个容积为V的大袋子,给出了每个骨头的体积和价值,求袋子能装的最大价值。

解题思路:

动态规划01背包问题。

#include<stdio.h>
int dp[1010][1010],v[1010],w[1010];
int maxx(int a,int b)
{
	if(a>=b)
		return a;
	else
		return b;
}
int main()
{
	int n,m,i,j,t;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d%d",&n,&m);
			for(i=1;i<=n;i++)
				scanf("%d",&w[i]);
			for(i=1;i<=n;i++)
				scanf("%d",&v[i]);
			for(i=0;i<=m;i++)
				dp[0][i]=0;
			for(i=1;i<=n;i++)
			{
				for(j=0;j<=m;j++)
					if(j<v[i])
						dp[i][j]=dp[i-1][j];
					else
						dp[i][j]=maxx(dp[i-1][j],dp[i-1][j-v[i]]+w[i]);
			}
			printf("%d\n",dp[n][m]);
		}
	}
	return 0;
}