Graveyard Design

Time Limit: 10000MS Memory Limit: 64000K
Case Time Limit: 2000MS

Description

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves.
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.

Input

Input file contains n — the number of graves to be located in the graveyard (1 <= n <= 1014 ).

Output

On the first line of the output file print k — the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l — the number of sections in the corresponding graveyard, followed by l integers — the lengths of section sides (successive positive integer numbers). Output line’s in descending order of l.

Sample Input

2030

Sample Output

2
4 21 22 23 24
3 25 26 27

思路:

首先就是注意数据范围,所以要用long long,然后就是尺取法去计算l和r的总和,之后用vector和pair去记录l和r。

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
vector<pair<long long, long long> > v;
int main() {
	long long n;
	scanf("%lld", &n);
	long long l = 1, r = 1, sum = 0, x = 0;
	while (1) {
		while (r * r <= n && sum < n) {
			sum += r * r;
			r++;
		}
		if (sum < n) break;
		if (sum == n) {
			v.push_back(make_pair(l, r));
		}
		sum -= l * l;
		l++;
	}
	cout << v.size() << endl;
	for (int i = 0; i < v.size(); i++) {
		int l = v[i].first, r = v[i].second;
		cout << r - l;
		for (int j = l; j < r; j++) {
			cout << " " << j;
		}
		cout << endl;
	}
	return 0;
}