题目描述

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.


输入

There are multiple test cases.

For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.

Proceed to the end of file.

输出

For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.

样例输入

5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7

样例输出

You are my elder
You are my brother

思路:

        存数组比较记录代数

具体代码:   

#include<stdio.h>
#include<string.h>
int str[1010];
int find(int n)
{
    int m=1;
    while(str[n]!=n)
    {
	n=str[n];
	m++;
    }
    return m;
}
int main()
{
	int n,i,a,b,m,c,t,j;
	
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=2010;i++)
			str[i] = i;
		while(n--)
		{
			scanf("%d%d",&a,&b);
			str[a]=b;
		}
		m=find(1);
		n=find(2);
		if(m==n)
			printf("You are my brother\n");
		
		else if(m>n)
			printf("You are my elder\n");
		
		else if(m<n)
			printf("You are my younger\n");
	}
	return 0;
}