题目链接:http://poj.org/problem?id=3669
Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5

Problem solving report:

Description: 起点在坐标系的(0,0),给出n组数据xi,yi,ti,表示在ti时间点(xi, yi)会被袭击,同时它的上下左右的邻接点都会被破坏,被破坏的点无法经过,问能否平安到达安全地带(永远不会被破坏的点)。
Problem solving: 先预处理出每个点被袭击的时间,然后进行BFS遍历,需要注意的是,被袭击的范围是x和y不超过300,但是可移动的点是整个第一象限。

Accepted Code:

#include <queue>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 305;
const int inf = 0x3f3f3f3f;
int spt[MAXN][MAXN];
bool vis[MAXN][MAXN];
int dir[][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
struct edge {
    int x, y, t;
    edge(int x_, int y_, int t_) : x(x_), y(y_), t(t_) {}
};
void Mark(int x, int y, int t) {
    spt[x][y] = min(spt[x][y], t);
    for (int i = 0; i < 4; i++) {
        int tx = x + dir[i][0];
        int ty = y + dir[i][1];
        if (tx >= 0 && ty >= 0)
            spt[tx][ty] = min(spt[tx][ty], t);
    }
}
int BFS(int x, int y) {
    queue <edge> Q;
    vis[x][y] = true;
    Q.push(edge(x, y, 0));
    while (!Q.empty()) {
        edge p = Q.front();
        Q.pop();
        if (spt[p.x][p.y] >= inf)
            return p.t;
        for (int i = 0; i < 4; i++) {
            int tx = p.x + dir[i][0];
            int ty = p.y + dir[i][1];
            if (tx >= 0 && ty >= 0 && !vis[tx][ty] && spt[tx][ty] > p.t + 1) {
                vis[tx][ty] = true;
                Q.push(edge(tx, ty, p.t + 1));
            }
        }
    }
    return -1;
}
int main() {
    int n, x, y, t;
    scanf("%d", &n);
    memset(spt, 0x3f, sizeof(spt));
    for (int i = 0; i < n; i++) {
        scanf("%d%d%d", &x, &y, &t);
        Mark(x, y, t);
    }
    printf("%d\n", BFS(0, 0));
    return 0;
}