零起点学算法11——求梯形面积

Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lld
 


Description

水题

 

Input

多组测试数据,每组输入3个浮点数,分别表示上底、下底和高,中间用逗号隔开(题目包含多组数据)

 

Output

输出梯形的面积,保留2位小数

 

Sample Input

2,4,5

 

Sample Output

15.00

 

HINT

 

注意输入语句 ,3个数之间用逗号隔开的


题目分析:水题。


#include <stdio.h>
int main()
{
	double a,b,h,s;
	while(scanf("%lf,%lf,%lf",&a,&b,&h)!=EOF)
	{
		s=(a+b)*h/2;
		printf("%.2lf\n",s);
	}
	
	return 0;
}