Description:

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines’ CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L’s and R’s where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

Input:

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

Output:

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete’’ should be printed

Sample Input:

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output:

5 4 8 11 13 4 7 2 1
not complete

题目链接

一直不会链表建立二叉树,这次找一道题用链表写一下。

题目给出节点值和位置,建立二叉树,若可以建树输出二叉树的层序遍历,否则输出“not complete”。

链表指针域有两个指向,一个左孩子,一个右孩子,按照给出信息建立二叉树,最后宽度优先搜索出层序遍历结果,若搜索出的节点无值。建树的时候如果指向节点已经有值则也是建树失败,也要记录(没有判断这个WA17发)!

AC代码:

#pragma comment(linker, "/STACK:102400000,102400000")
#include <bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
#define mp make_pair
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
const int INF = 0x3f3f3f3f;
const int maxn = 4e5+5;
const int mod = 1e9+7;
const double eps = 1e-8;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
bool Finish_read;
template<class T>inline void read(T &x){Finish_read=0;x=0;int f=1;char ch=getchar();while(!isdigit(ch)){if(ch=='-')f=-1;if(ch==EOF)return;ch=getchar();}while(isdigit(ch))x=x*10+ch-'0',ch=getchar();x*=f;Finish_read=1;}

struct tree {
	ll data;
	tree *LeftChild, *RightChild;
	tree(): data(INF), LeftChild(NULL), RightChild(NULL) {}
};

bool fail;
tree *root;
vector<ll> ans;

void addtree(ll x, string index) {
	tree *f = root;
	if (index == "") {
		f -> data = x;
		return;
	}
	for (int i = 0; i < int(index.size()); ++i) {
		if (index[i] == 'L') {
			if (f -> LeftChild == NULL) {
				f -> LeftChild = new tree;
			}
			f = f -> LeftChild;
		}
		else if (index[i] == 'R') {
			if (f -> RightChild == NULL) {
				f -> RightChild = new tree;
			}
			f = f -> RightChild;
		}
	}
	if (f -> data != INF) {
		fail = 1;
	}
	f -> data = x;
}

bool find() {
	queue<tree*> que;
	ans.clear();
	que.push(root);
	while (!que.empty()) {
		tree *temp = que.front();
		que.pop();
		if (temp -> data == INF) {
			return 0;
		}
		ans.pb(temp -> data);
		if (temp -> LeftChild != NULL) {
			que.push(temp -> LeftChild);
		}
		if (temp -> RightChild != NULL) {
			que.push(temp -> RightChild);
		}
	}
	return 1;
}

void remove(tree *u) {
	if (u == NULL) {
		return;
	}
	remove(u -> LeftChild);
	remove(u -> RightChild);
	delete u;
}

bool read() {
	string Input;
	ll num;
	string str;
	remove(root);
	root = NULL;
	fail = 0;
	while (cin >> Input) {
		if (root == NULL) {
			root = new tree;
		}
		num = 0;
		str.clear();
		if (Input == "()") {
			return 1;
		}
		int i;
		for (i = 1; Input[i] != ','; ++i) {
			num = num * 10 + Input[i] - '0';
		}
		++i;
		for (; Input[i] != ')'; ++i) {
			str += Input[i];
		}
		addtree(num, str);
	}
	return 0;
}

int main(int argc, char *argv[]) {
#ifndef ONLINE_JUDGE
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
#endif
	while (read()) {
		if (find() && !fail) {
			for (int i = 0; i < int(ans.size()); ++i) {
				if (i) {
					cout << " ";
				}
				cout << ans[i];
			}
			cout << endl;
		}
		else {
			cout << "not complete" << endl;
		}
	}
#ifndef ONLINE_JUDGE
	fclose(stdin);
	fclose(stdout);
	system("gedit out.txt");
#endif
    return 0;
}