Rescue

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

 

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

 

 

Sample Input


 

7 8

#.#####.

#.a#..r.

#..#x...

..#..#.#

#...##..

.#......

........

Sample Output

13

题意描述:
由‘r’去寻找‘a’,地图中‘.’为道路,‘x’为警卫,‘#’为墙,‘.’需要一个时间,‘x’需要两个时间,求找到‘a’的最短时间。

解题思路:
运用广搜一层一层查找最先找到的就是最小时间,从队首开始查找并更新队首,每次遇到符合条件的坐标加入队列并扩充队列,当队首为‘x’时,将此点更新为‘.’再次加入队列并时间加一,从下一位置继续查找,当找到‘a’时,输出时间。

错误分析:

第一次做的时候考虑简单了,是遇到‘x’直接加二了,遇到一些特殊样例会答案错误。

如:  2   6

      axxxxr

     ......

#include<stdio.h>
#include<string.h>
int num[1000000];
char a[210][210];
int book[210][210];
int next[4][2]={0,1,
				1,0,
				0,-1,
				-1,0
				};
int n,m,startx,starty;
int bfs()
{
		int k,head,tail,tx,ty,x,y,t;
		head=0;
		tail=0;
		num[tail++]=startx;//未用结构体,直接用了队列,下面三个数的位置不能换 
		num[tail++]=starty;
		num[tail++]=0;
		while(head<tail)
		{
			x=num[head++];
			y=num[head++];
			t=num[head++];
			if(a[x][y]=='a')
			{
				return t;
			}
			else if(a[x][y]=='x')//若为'x'转化为点加入队列时间加一从下一位置重新查找 
			{
				a[x][y]='.';
				num[tail++]=x;
				num[tail++]=y;
				num[tail++]=t+1;
				continue;
			}
			for(k=0;k<=3;k++)
			{
				tx=x+next[k][0];
				ty=y+next[k][1];
				if(tx>=0&&tx<n&&ty>=0&&ty<m)
				{
					if(a[tx][ty]!='#'&&book[tx][ty]==0)
					{
						book[tx][ty]=1;
						num[tail++]=tx;
						num[tail++]=ty;
						num[tail++]=t+1;
						
					}
				}
			}
		}
		return -1;
}


int main()
{
	
	int i,j,flag;
	
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++)
			scanf("%s",a[i]);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(a[i][j]=='r')
				{
					startx=i;
					starty=j;
				}
			}
		book[startx][starty]=1;
		flag=bfs();
		if(flag==-1)
			printf("Poor ANGEL has to stay in the prison all his life.\n");
		else
			printf("%d\n",flag);
	}
	return 0;
}