Silver Cow Party

Time Limit: 2000MS Memory Limit: 65536K

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2…M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

思路:

题目需要求来去的最大值,那就写一个Dijkstra算法,然后每到一个点就是将起点到终点的加上终点到起点的就是需要的答案了,(在写Dijkstra的时候用了堆优化的优先队列,没有的话可能会TLE)

#include <iostream>
#include <cstdio>
#include <map>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;
typedef pair<int, int> p;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
vector<p > v[maxn];
int Dijkstra(int st, int ed) {
    priority_queue<p, vector<p >, greater<p> > q;
    int d[maxn];
    memset(d, inf, sizeof(d));
    d[st] = 0;
    q.push(make_pair(0, st));
    while (!q.empty()) {
        int now = q.top().second;
        q.pop();
        for (int i = 0; i < v[now].size(); i++) {
            int x = v[now][i].first;
            if (d[x] > d[now] + v[now][i].second) {
                d[x] = d[now] + v[now][i].second;
                q.push(make_pair(d[x], x));
            }
        }
    }
    if (d[ed] != inf) return d[ed];
    else return 0;
}
int main() {
    ios::sync_with_stdio(false);
    int n, m, x, Max = 0;
    scanf("%d %d %d", &n, &m, &x);
    for (int i = 0; i < m; i++) {
        int a, b, c;
        scanf("%d %d %d", &a, &b, &c);
        v[a].push_back(make_pair(b, c));
    }
    for (int i = 1; i <= n; i++) {
        int ans = Dijkstra(i, x) + Dijkstra(x, i);
        Max = max(Max, ans);
    }
    printf("%d", Max);
    return 0;
}