7-9 堆中的路径 (25 分)
将一系列给定数字插入一个初始为空的小顶堆H[]
。随后对任意给定的下标i
,打印从H[i]
到根结点的路径。
输入格式:
每组测试第1行包含2个正整数N和M(≤1000),分别是插入元素的个数、以及需要打印的路径条数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。最后一行给出M个下标。
输出格式:
对输入中给出的每个下标i
,在一行中输出从H[i]
到根结点的路径上的数据。数字间以1个空格分隔,行末不得有多余空格。
输入样例:
5 3
46 23 26 24 10
5 4 3
输出样例:
24 23 10
46 23 10
26 10
题意 :中文题,不解释;
题解:水题看代码解释吧。
方法一:
#include <iostream>
#include <cstdlib>
using namespace std;
const int mindata=-200000;
typedef struct hnode *heap;
int n,m;
struct hnode{
int *data;
int sizee;
int cap;
};
typedef heap minheap;
minheap creat(int minsize){//创建空树
minheap h= new hnode;
h->data=(int*)malloc((minsize+1)*sizeof(int));
h->sizee=0;
h->cap=minsize;
h->data[0]=mindata;
return h;
}
bool isfull(minheap h){//判断是否满了,这个题用不到
return (h->sizee==h->cap);
}
bool insert(minheap h,int x){//插入数字,加调整位置
int i;
if(isfull(h)){
return false;
}
i=++h->sizee;
for (;h->data[i/2]>x;i/=2){
h->data[i]=h->data[i/2];
}
h->data[i]=x;
return true;
}
int main(){
cin >> n >> m;
minheap w=creat(n);
for (int i = 0; i < n;i++){
int x;
cin >> x;
insert(w,x);
}
while(m--){
int z;
cin >> z;
bool f=true;
for (int i = z;i >= 1; i/=2){//路径就是下标除以二的过程
if(f) {
cout << w->data[i];
f=!f;
}
else{
cout << " " << w->data[i];
}
}
cout << endl;
}
return 0;
}
方法二:
#include <iostream>
using namespace std;
const int MAX = 1002;
int a[MAX];
int main(){
int n,m;
cin >> n >> m;
for (int i = 1; i <= n;i++){//建立最小堆
cin >> a[i];
int k=i;
while(k>1&&a[k]<a[k/2]){
swap(a[k],a[k/2]);
k/=2;
}
}
while(m--){
int z;
cin >> z;
bool f=true;
for (int i = z;i >= 1; i/=2){//输出,路径就是下标除以2,输出注意格式
if(f) {
cout << a[i];
f=!f;
}
else{
cout << " " << a[i];
}
}
cout << endl;
}
return 0;
}