ROADS
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15598   Accepted: 5622

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

Source



#include<stdio.h>  
#include<string.h>  
const int N=1010;  
const int INF=1e6;  
  
struct Edge  
{  
    int s,e,len,cost;  
    int net;  
}edge[10*N];  
  
int n,m,e_num,head[N],vis[N];  
int ans;  
  
void AddEdge(int a,int b,int c,int d)  
{  
    edge[e_num].s=a;    edge[e_num].e=b;  
    edge[e_num].len=c;  edge[e_num].cost=d;  
    edge[e_num].net=head[a];  
    head[a]=e_num++;  
}  
  
void dfs(int id,int dist,int money)  
{  
    if(dist>ans)
        return;  
    if(id==n&&money>=0&&dist<ans)  
        ans=dist;  
    for(int i=head[id];i!=-1;i=edge[i].net)  
    {  
        int u=edge[i].e;  
        if(vis[u]==0&&money>=edge[i].cost)  
        {  
            vis[u]=1;  
            dfs(u,dist+edge[i].len,money-edge[i].cost);  
            vis[u]=0;  
        }  
    }  
}  
  
int main()  
{  
    int i,a,b,c,d,k;  
    while(~scanf("%d%d%d",&k,&n,&m))  
    {  
        e_num=0;  
        memset(head,-1,sizeof(head));  
        for(int i=0;i<m;i++)  
        {  
            scanf("%d%d%d%d",&a,&b,&c,&d);  
            AddEdge(a,b,c,d);  
        }  
        ans=INF;  
        memset(vis,0,sizeof(vis));  
        dfs(1,0,k);  
        printf("%d\n",ans<INF?ans:-1);  
    }  
}