Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

题意:

       有任意堆石子,两个选手A和B,他们每次可以移动任意一堆中的石子,移动后也可以放在其他石子不为0的堆中,总是A先,问胜负。

思路:

(1) 只有一堆时,先手必赢。

(2)有两堆时,只有两堆相同的时候先手会输。若两堆不同,先手可以造成两堆相同的局面从而不输。

(3)有三堆时,先手可以先拿走一堆,制造两堆相同的情况。

            ……

由此发现,将n堆石子排序,当堆数为偶数并且是成对出现的,则先手必输。因为先手并不能取光所有的,而后手只要模仿先手的行为就能一直有石子可取。

继续推理发现,只有在上述情况下先手必输。

代码:

#include<stdio.h>
int main()
{
	int n,i,j,t;
	int a[110];
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(i=1;i<n;i++)
			for(j=i+1;j<=n;j++)
			{
				if(a[i]>a[j])
				{
					t=a[i];
					a[i]=a[j];
					a[j]=t;
				}
			}
		if(n%2==1)
		{
			printf("1\n");
		}
		else
		{
			for(i=1;i<=n;i=i+2)
			{
				if(a[i]!=a[i+1])
				{
					printf("1\n");
					break;
				}
			}
			if(i>n)
				printf("0\n");
		}
	 } 
	 return 0;
}